GitHub Advisoryadvisory · Go

GHSA-pxq6-2prw-chj9 Moby has an Off-by-one error in its plugin privilege validation

MEDIUM Published 2026-03-27 Modified 2026-03-31 Official page ↗
Aliases
CVE-2026-33997
Ecosystem
Go
Packages
github.com/docker/docker, github.com/moby/moby/v2, github.com/moby/moby
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
Weaknesses
CWE-193
Reviewed
2026-03-27

Affected packages

• Go github.com/docker/docker: < 29.3.1 (no fix yet) • Go github.com/moby/moby/v2: < 2.0.0-beta.8 → fixed in 2.0.0-beta.8 • Go github.com/moby/moby: < 29.3.1 (no fix yet)

Description

Summary A security vulnerability has been detected that allows plugins privilege validation to be bypassed during `docker plugin install`. Due to an error in the daemon's privilege comparison logic, the daemon may incorrectly accept a privilege set that differs from the one approved by the user. Plugins that request exactly one privilege are also affected, because no comparison is performed at all. Impact If plugins are not in use, there is no impact. When a plugin is installed, the daemon computes the privileges required by the plugin's configuration and compares them with the privileges approved during installation. A malicious plugin can exploit this bug so that the daemon accepts privileges that differ from what was intended to be approved. Anyone who depends on the plugin installation approval flow as a meaningful security boundary is potentially impacted. Depending on the privilege set involved, this may include highly sensitive plugin permissions such as broad device access. For consideration: exploitation still requires a plugin to be installed from a malicious source, and Docker plugins are relatively uncommon. Docker Desktop also does not support plugins. Workarounds If unable to update immediately: • Do not install plugins from untrusted sources • Carefully review all privileges requested during `docker plugin install` • Restrict access to the Docker daemon to trusted parties, following the principle of least privilege • Avoid relying on plugin privilege approval as the only control boundary for sensitive environments Credits • Reported by Cody ([email protected], PGP 0x9FA5B73E)

Related

Alias · CVE (1)

  • CVE-2026-33997 Moby is an open source container framework. vulnerability

Weakness · CWE (1)

  • CWE-193 Off-by-one Error weakness

References