GitHub Advisoryadvisory · RubyGems
GHSA-pxqr-8v54-m2hj Cross-site request forgery in rails_admin
HIGH
Official page ↗
- Aliases
- CVE-2016-10522
- Ecosystem
- RubyGems
- Packages
- rails_admin
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-352
- Reviewed
- 2020-06-16
Affected packages
• RubyGems rails_admin: >= 1.0.0, < 1.1.1 → fixed in 1.1.1
Description
rails_admin ruby gem <v1.1.1 is vulnerable to cross-site request forgery (CSRF) attacks. Non-GET methods were not validating CSRF tokens and, as a result, an attacker could hypothetically gain access to the application administrative endpoints exposed by the gem.
Related
Alias · CVE (1)
- CVE-2016-10522 rails_admin ruby gem <v1.1.1 is vulnerable to cross-site request forgery (CSRF) attacks. vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2016-10522 advisory
- https://github.com/railsadminteam/rails_admin/commit/b13e879eb93b661204e9fb5e55f7afa4f397537a web
- https://github.com/advisories/GHSA-pxqr-8v54-m2hj advisory
- https://github.com/railsadminteam/rails_admin package
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rails_admin/CVE-2016-10522.yml web
- https://www.sourceclear.com/registry/security/cross-site-request-forgery-csrf-/ruby/sid-3173 web