GitHub Advisoryadvisory · Maven

GHSA-q4q3-r45f-7gwg Apache Geode vulnerable to Deserialization of Untrusted Data

CRITICAL Published 2022-09-01 Modified 2023-03-10 Official page ↗
Aliases
CVE-2022-37021
Ecosystem
Maven
Packages
org.apache.geode:geode-core
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2023-03-10

Affected packages

• Maven org.apache.geode:geode-core: < 1.12.16 → fixed in 1.12.16 • Maven org.apache.geode:geode-core: >= 1.13.0, < 1.13.5 → fixed in 1.13.5 • Maven org.apache.geode:geode-core: >= 1.14.0, < 1.14.1 → fixed in 1.14.1

Description

Apache Geode versions up to 1.12.5, 1.13.4 and 1.14.0 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 8. Any user still on Java 8 who wishes to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15 and Java 11. If upgrading to Java 11 is not possible, then upgrade to Apache Geode 1.15 and specify "--J=-Dgeode.enableGlobalSerialFilter=true" when starting any Locators or Servers. Follow the documentation for details on specifying any user classes that may be serialized/deserialized with the "serializable-object-filter" configuration option. Using a global serial filter will impact performance.

Related

Alias · CVE (1)

  • CVE-2022-37021 Apache Geode versions up to 1.12.5, 1.13.4 and 1.14.0 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on… vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References