GitHub Advisoryadvisory · Maven

GHSA-q564-vvx8-9388 CSRF vulnerability in Jenkins warnings Plugin allows remote code execution

HIGH Published 2022-05-24 Modified 2023-10-27 Official page ↗
Aliases
CVE-2020-2280
Ecosystem
Maven
Packages
org.jvnet.hudson.plugins:warnings
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-352
Reviewed
2022-12-19

Affected packages

• Maven org.jvnet.hudson.plugins:warnings: < 5.0.2 → fixed in 5.0.2

Description

warnings Plugin 5.0.1 and earlier does not require POST requests for a form validation method intended for testing custom warnings parsers, resulting in a cross-site request forgery (CSRF) vulnerability. This vulnerability allows attackers to execute arbitrary code. warnings Plugin 5.0.2 requires POST requests for the affected form validation method. This vulnerability was caused by an incomplete fix to SECURITY-1295.

Related

Alias · CVE (1)

  • CVE-2020-2280 A cross-site request forgery (CSRF) vulnerability in Jenkins Warnings Plugin 5.0.1 and earlier allows attackers to execute arbitrary code. vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References