GitHub Advisoryadvisory · Maven

GHSA-q9w2-h4cw-8ghp Apache RocketMQ Vulnerable to Unauthorized Exposure of Sensitive Data

MEDIUM Published 2024-07-22 Modified 2024-09-10 Official page ↗
Aliases
CVE-2024-23321
Ecosystem
Maven
Packages
org.apache.rocketmq:rocketmq-all
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-200
Reviewed
2024-07-22

Affected packages

• Maven org.apache.rocketmq:rocketmq-all: >= 4.5.2, < 5.3.0 → fixed in 5.3.0

Description

For RocketMQ versions 5.2.0 and below, under certain conditions, there is a risk of exposure of sensitive Information to an unauthorized actor even if RocketMQ is enabled with authentication and authorization functions. An attacker, possessing regular user privileges or listed in the IP whitelist, could potentially acquire the administrator's account and password through specific interfaces. Such an action would grant them full control over RocketMQ, provided they have access to the broker IP address list. To mitigate these security threats, it is strongly advised that users upgrade to version 5.3.0 or newer. Additionally, we recommend users to use RocketMQ ACL 2.0 instead of the original RocketMQ ACL when upgrading to version Apache RocketMQ 5.3.0.

Related

Alias · CVE (1)

  • CVE-2024-23321 For RocketMQ versions 5.2.0 and below, under certain conditions, there is a risk of exposure of sensitive Information to an unauthorized… vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References