GitHub Advisoryadvisory · Maven

GHSA-qf8g-vpwp-6579 Apache Geode versions deserialization of untrusted datawhen using JMX over RMI on Java 11

HIGH Published 2022-09-01 Modified 2022-09-16 Official page ↗
Aliases
CVE-2022-37022
Ecosystem
Maven
Packages
org.apache.geode:geode-core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2022-09-16

Affected packages

• Maven org.apache.geode:geode-core: < 1.15.0 → fixed in 1.15.0

Description

Apache Geode versions up to 1.12.2 and 1.13.2 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 11. Any user wishing to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15. Use of 1.15 on Java 11 will automatically protect JMX over RMI against deserialization attacks. This should have no impact on performance since it only affects JMX/RMI which Gfsh uses to communicate with the JMX Manager which is hosted on a Locator.

Related

Alias · CVE (1)

  • CVE-2022-37022 Apache Geode versions up to 1.12.2 and 1.13.2 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 11. vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References