GitHub Advisoryadvisory · Go
GHSA-qj6r-fhrc-jj5r Remote denial of service in Hyperledger Fabric Gateway
HIGH
Official page ↗
- Aliases
- CVE-2022-36023
- Ecosystem
- Go
- Packages
- github.com/hyperledger/fabric
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2022-10-13
Affected packages
• Go github.com/hyperledger/fabric: >= 2.4.0, < 2.4.6 → fixed in 2.4.6
Description
Impact
If a gateway client application sends a malformed request to a gateway peer it may crash the peer node.
This fix checks for the malformed gateway request and returns an error to the gateway client.
Patches
Fixed in v2.4.6.
Workarounds
None, users must upgrade to v2.4.6.
References
https://github.com/hyperledger/fabric/releases/tag/v2.4.6
For more information
If you have any questions or comments about this advisory:
• Open an issue in Fabric
Credits
Thank you to Haosheng Wang of OPPO ZIWU Security Lab for this disclosure.
Related
Alias · CVE (1)
- CVE-2022-36023 Hyperledger Fabric is an enterprise-grade permissioned distributed ledger framework for developing solutions and applications. vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/hyperledger/fabric/security/advisories/GHSA-qj6r-fhrc-jj5r web
- https://nvd.nist.gov/vuln/detail/CVE-2022-36023 advisory
- https://github.com/hyperledger/fabric/pull/3572 web
- https://github.com/hyperledger/fabric/pull/3576 web
- https://github.com/hyperledger/fabric/pull/3577 web
- https://github.com/hyperledger/fabric package
- https://github.com/hyperledger/fabric/releases/tag/v2.4.6 web