GitHub Advisoryadvisory · Maven

GHSA-qq5r-98hh-rxc9 Apache Tomcat - Security constraint bypass with HTTP/0.9

LOW Published 2026-02-17 Modified 2026-06-29 Official page ↗
Aliases
CVE-2026-24733
Ecosystem
Maven
Packages
org.apache.tomcat:tomcat-coyote
Severity
Low
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U
Weaknesses
CWE-20
Reviewed
2026-02-19

Affected packages

• Maven org.apache.tomcat:tomcat-coyote: >= 11.0.0-M1, < 11.0.15 → fixed in 11.0.15 • Maven org.apache.tomcat:tomcat-coyote: >= 10.1.0-M1, < 10.1.50 → fixed in 10.1.50 • Maven org.apache.tomcat:tomcat-coyote: < 9.0.113 → fixed in 9.0.113

Description

Improper Input Validation vulnerability in Apache Tomcat. Tomcat did not limit HTTP/0.9 requests to the GET method. If a security constraint was configured to allow HEAD requests to a URI but deny GET requests, the user could bypass that constraint on GET requests by sending a (specification invalid) HEAD request using HTTP/0.9. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0.M1 through 9.0.112. Older, EOL versions are also affected. Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2026-24733 Improper Input Validation vulnerability in Apache Tomcat. vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References