GitHub Advisoryadvisory · Packagist

GHSA-qr95-4mq5-r3fh Phar unserialization vulnerability in phpMussel

HIGH Published 2020-06-10 Modified 2022-10-11 Official page ↗
Aliases
CVE-2020-4043
Ecosystem
Packagist
Packages
phpmussel/phpmussel, maikuolan/phpmussel
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
Weaknesses
CWE-502
Reviewed
2020-06-10

Affected packages

• Packagist phpmussel/phpmussel: >= 1.0.0, < 1.6.0 → fixed in 1.6.0 • Packagist maikuolan/phpmussel: >= 1.0.0, < 1.6.0 → fixed in 1.6.0

Description

Impact _What kind of vulnerability is it? Who is impacted?_ Anyone using >= v1.0.0 = v1.6.0 (the earliest safe version) will resolve the problem. However, as multiple new major versions have been released since that version, upgrading to the latest available version is recommended, in order to protect against any potential future vulnerabilities, unknown at the time of writing this advisory. Workarounds _Is there a way for users to fix or remediate the vulnerability without upgrading?_ Yes. In the package's configuration, disable archive checking by setting `check_archives` to `false` (thus avoiding execution of the affected parts of the codebase entirely). References _Are there any links users can visit to find out more?_ Yes. The vulnerability is documented at SECURITY.md and also at #167. For more information If you have any questions or comments about this advisory: • Comment at the issue linked to this advisory, or.. • Contact the package author.

Related

Alias · CVE (1)

  • CVE-2020-4043 phpMussel from versions 1.0.0 and less than 1.6.0 has an unserialization vulnerability in PHP's phar wrapper. vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References