GitHub Advisoryadvisory · Packagist

GHSA-r42c-3rr2-jrfp Concrete CMS is Vulnerable to Cross-Site Request Forgery

HIGH Published 2026-05-21 Modified 2026-06-23 Official page ↗
Aliases
CVE-2026-8140
Ecosystem
Packagist
Packages
concrete5/concrete5
Severity
High
CVSS vector
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Weaknesses
CWE-352
Reviewed
2026-06-23

Affected packages

• Packagist concrete5/concrete5: < 9.5.1 → fixed in 9.5.1

Description

Concrete CMS 9.5.0 and below does not validate a CSRF token before processing requests to /dashboard/extend/install/download/. The download() method in concrete/controllers/single_page/dashboard/extend/install.php checks only the canInstallPackages() permission before fetching a remote marketplace package and writing it to the server's DIR_PACKAGES directory. Because the endpoint is a state-changing GET route with no token enforcement, an attacker who can cause an authenticated administrator to visit a crafted page can force an arbitrary marketplace package to be downloaded. In order to be vulnerable, the victim must be passing canInstallPackages() and the site must be connected to the Concrete marketplace. Concrete CMS thanks https://github.com/maru1009  for reporting this issue.

Related

Alias · CVE (1)

  • CVE-2026-8140 Concrete CMS 9.5.0 and below does not validate a CSRF token before processing requests to /dashboard/extend/install/download/<remoteId>. vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References