GitHub Advisoryadvisory · Packagist
GHSA-rc94-7v55-wmg6 Subrion CMS CSRF Vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2017-15063
- Ecosystem
- Packagist
- Packages
- intelliants/subrion
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-352
- Reviewed
- 2023-07-26
Affected packages
• Packagist intelliants/subrion: >= 4.1, < 4.2.0 → fixed in 4.2.0
Description
There are CSRF vulnerabilities in Subrion CMS 4.1.x through 4.1.5, and before 4.2.0, because of a logic error. Although there is functionality to detect CSRF, it is called too late in the ia.core.php code, allowing (for example) an attack against the query parameter to panel/database.
Related
Alias · CVE (1)
- CVE-2017-15063 There are CSRF vulnerabilities in Subrion CMS 4.1.x through 4.1.5, and before 4.2.0, because of a logic error. vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-15063 advisory
- https://github.com/intelliants/subrion/issues/547 web
- https://github.com/intelliants/subrion/issues/570 web
- https://github.com/intelliants/subrion/commit/5fdf03af1a7d89c3692faa155e17457153020dca web
- https://github.com/intelliants/subrion/commit/65fb937a588d730e57da0c2c5ca3bc4b9c2b5628 web