GitHub Advisoryadvisory · Maven
GHSA-rf8w-7c3g-7h3g Jenkins GitHub Integration Plugin has a cross-site request forgery (CSRF) vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2026-48925
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:github-integration-parent
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2026-07-01
Affected packages
• Maven org.jenkins-ci.plugins:github-integration-parent: < 0.7.4 → fixed in 0.7.4
Description
Jenkins GitHub Integration Plugin 0.7.3 and earlier does not require POST requests for an HTTP endpoint, resulting in a cross-site request forgery (CSRF) vulnerability.
This vulnerability allows attackers to trigger a build for a pull request.
GitHub Integration Plugin 0.7.4 requires POST requests for the affected HTTP endpoint.
Related
Alias · CVE (1)
- CVE-2026-48925 A cross-site request forgery (CSRF) vulnerability in Jenkins GitHub Integration Plugin 0.7.3 and earlier allows attackers to attackers to… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness