GitHub Advisoryadvisory · Maven
GHSA-rg58-xhh7-mqjw Apache Struts has a Denial of Service vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2025-66675
- Ecosystem
- Maven
- Packages
- org.apache.struts:struts2-core
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
- Weaknesses
- CWE-459
- Reviewed
- 2025-12-10
Affected packages
• Maven org.apache.struts:struts2-core: >= 2.0.0, < 6.8.0 → fixed in 6.8.0
• Maven org.apache.struts:struts2-core: >= 7.0.0, < 7.1.1 → fixed in 7.1.1
Description
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion.
This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3.
Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
Related
Alias · CVE (1)
- CVE-2025-66675 Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. vulnerability
Weakness · CWE (1)
- CWE-459 Incomplete Cleanup weakness