GitHub Advisoryadvisory · PyPI
GHSA-rp8m-h266-53jh python-apt Flawed Package Integrity Check
MEDIUM
Official page ↗
- Aliases
- CVE-2019-15795
- Ecosystem
- PyPI
- Packages
- python-apt
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-327
- Reviewed
- 2023-07-18
Affected packages
• PyPI python-apt: < 0.8.3ubuntu7.5 → fixed in 0.8.3ubuntu7.5
• PyPI python-apt: >= 0.9.0, < 0.9.3.5ubuntu3 → fixed in 0.9.3.5ubuntu3
• PyPI python-apt: >= 1.0.0, < 1.1.0 → fixed in 1.1.0
• PyPI python-apt: >= 1.2.0, < 1.6.5ubuntu0.1 → fixed in 1.6.5ubuntu0.1
• PyPI python-apt: >= 1.7.0, < 1.9.0ubuntu1.2 → fixed in 1.9.0ubuntu1.2
Description
python-apt only checks the MD5 sums of downloaded files in `Version.fetch_binary()` and `Version.fetch_source()` of apt/package.py in version 1.9.0ubuntu1 and earlier. This allows a man-in-the-middle attack which could potentially be used to install altered packages and has been fixed in versions 1.9.0ubuntu1.2, 1.6.5ubuntu0.1, 1.1.0~beta1ubuntu0.16.04.7, 0.9.3.5ubuntu3+esm2, and 0.8.3ubuntu7.5.
Related
Alias · CVE (1)
- CVE-2019-15795 python-apt only checks the MD5 sums of downloaded files in `Version.fetch_binary()` and `Version.fetch_source()` of apt/package.py in… vulnerability
Weakness · CWE (1)
- CWE-327 Use of a Broken or Risky Cryptographic Algorithm weakness