GitHub Advisoryadvisory · Maven
GHSA-rrhf-32rq-f28h Apache Linkis DatasourceManager module has deserialization vulnerability
CRITICAL
Official page ↗
- Aliases
- CVE-2023-29216
- Ecosystem
- Maven
- Packages
- org.apache.linkis:linkis-datasource
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
- Reviewed
- 2023-04-10
Affected packages
• Maven org.apache.linkis:linkis-datasource: < 1.3.2 → fixed in 1.3.2
Description
In Apache Linkis <=1.3.1, because the parameters are not effectively filtered, the attacker can use the MySQL data source and malicious parameters to configure a new data source to trigger a deserialization vulnerability, eventually leading to remote code execution. Users should upgrade their version of Linkis to version 1.3.2.
Related
Alias · CVE (1)
- CVE-2023-29216 In Apache Linkis <=1.3.1, because the parameters are not effectively filtered, the attacker uses the MySQL data source and malicious… vulnerability
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness