GitHub Advisoryadvisory · Maven
GHSA-rvww-w62m-hch8 CSRF vulnerability in Jenkins Lockable Resources Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2020-2281
- Ecosystem
- Maven
- Packages
- org.6wind.jenkins:lockable-resources
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
- Weaknesses
- CWE-352
- Reviewed
- 2023-01-05
Affected packages
• Maven org.6wind.jenkins:lockable-resources: < 2.9 → fixed in 2.9
Description
Lockable Resources Plugin 2.8 and earlier does not require POST requests for several HTTP endpoints, resulting in a cross-site request forgery (CSRF) vulnerability. This vulnerability allows attackers to reserve, unreserve, unlock, and reset resources. Lockable Resources Plugin 2.9 requires POST requests for the affected HTTP endpoints.
Related
Alias · CVE (1)
- CVE-2020-2281 A cross-site request forgery (CSRF) vulnerability in Jenkins Lockable Resources Plugin 2.8 and earlier allows attackers to reserve,… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-2281 advisory
- https://github.com/jenkinsci/lockable-resources-plugin/commit/50ab82498f792775a761e6f4937607b240ecde67 web
- https://github.com/jenkinsci/lockable-resources-plugin package
- https://www.jenkins.io/security/advisory/2020-09-23/#SECURITY-1958 web
- http://www.openwall.com/lists/oss-security/2020/09/23/1 web