GitHub Advisoryadvisory · PyPI

GHSA-rxc4-3w6r-4v47 vllm API endpoints vulnerable to Denial of Service Attacks

HIGH Published 2025-08-21 Modified 2026-07-17 Official page ↗
Aliases
CVE-2025-48956
Ecosystem
PyPI
Packages
vllm
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2025-08-21

Affected packages

• PyPI vllm: >= 0.1.0, < 0.10.1.1 → fixed in 0.10.1.1

Description

Summary A Denial of Service (DoS) vulnerability can be triggered by sending a single HTTP GET request with an extremely large header to an HTTP endpoint. This results in server memory exhaustion, potentially leading to a crash or unresponsiveness. The attack does not require authentication, making it exploitable by any remote user. Details The vulnerability leverages the abuse of HTTP headers. By setting a header such as `X-Forwarded-For` to a very large value like `("A" * 5_800_000_000)`, the server's HTTP parser or application logic may attempt to load the entire request into memory, overwhelming system resources. Impact _What kind of vulnerability is it? Who is impacted?_ Type of vulnerability: Denial of Service (DoS) Resolution Upgrade to a version of vLLM that includes appropriate HTTP limits by deafult, or use a proxy in front of vLLM which provides protection against this issue.

Related

Alias · CVE (1)

  • CVE-2025-48956 vLLM is an inference and serving engine for large language models (LLMs). vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References