GitHub Advisoryadvisory · Maven
GHSA-v3cg-7r9h-r2g6 Field-level security issue with .keyword fields in OpenSearch
MEDIUM
Official page ↗
- Aliases
- CVE-2023-23613
- Ecosystem
- Maven
- Packages
- org.opensearch.plugin:opensearch-security
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-200
- Reviewed
- 2023-01-24
Affected packages
• Maven org.opensearch.plugin:opensearch-security: < 1.3.8 → fixed in 1.3.8
• Maven org.opensearch.plugin:opensearch-security: >= 2.0.0, < 2.5.0 → fixed in 2.5.0
Description
Advisory title: Field-level security issue with .keyword fields
Affected versions:
OpenSearch 1.0.0-1.3.7 and 2.0.0-2.4.1
Patched versions:
OpenSearch 1.3.8 and 2.5.0
Impact:
There is an issue in the implementation of field-level security (FLS) and field masking where rules written to explicitly exclude fields are not correctly applied for certain queries that rely on their auto-generated .keyword fields.
This issue is only present for authenticated users with read access to the indexes containing the restricted fields.
Workaround:
FLS rules that use explicit exclusions can be written to grant explicit access instead. Policies authored in this way are not subject to this issue.
Patches:
OpenSearch versions 1.3.8 and 2.5.0 contain a fix for this issue.
For more information:
If you have any questions or comments about this advisory, please contact AWS/Amazon Security via our issue reporting page (https://aws.amazon.com/security/vulnerability-reporting/) or directly via email to [email protected]. Please do not create a public GitHub issue.
Related
Alias · CVE (1)
- CVE-2023-23613 OpenSearch is an open source distributed and RESTful search engine. vulnerability
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness