GitHub Advisoryadvisory · Maven

GHSA-v62j-cxhh-fq22 graphql-java vulnerable to Denial of Service via GraphQL query that consumes CPU resources

HIGH Published 2022-09-13 Modified 2022-09-16 Official page ↗
Aliases
CVE-2022-37734
Ecosystem
Maven
Packages
com.graphql-java:graphql-java
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2022-09-16

Affected packages

• Maven com.graphql-java:graphql-java: < 17.4 → fixed in 17.4 • Maven com.graphql-java:graphql-java: >= 18.0, < 18.3 → fixed in 18.3

Description

graphql-java before 19.0, 18.3, and 17.4 is vulnerable to Denial of Service. An attacker send a malicious GraphQL query that consumes CPU resources. The fixed versions are 19.0, 18.3, and 17.4.

Related

Alias · CVE (1)

  • CVE-2022-37734 graphql-java before19.0 is vulnerable to Denial of Service. vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References