GitHub Advisoryadvisory · Packagist
GHSA-v6fp-h79x-9rqc phpMyAdmin CSRF vulnerability allowing arbitrary SQL execution
HIGH
Official page ↗
- Aliases
- CVE-2018-10188
- Ecosystem
- Packagist
- Packages
- phpmyadmin/phpmyadmin
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-352
- Reviewed
- 2024-04-24
Affected packages
• Packagist phpmyadmin/phpmyadmin: >= 4.8, < 4.8.0.1 → fixed in 4.8.0.1
Description
phpMyAdmin 4.8.0 before 4.8.0-1 has CSRF, allowing an attacker to execute arbitrary SQL statements, related to js/db_operations.js, js/tbl_operations.js, libraries/classes/Operations.php, and sql.php.
Related
Alias · CVE (1)
- CVE-2018-10188 phpMyAdmin 4.8.0 before 4.8.0-1 has CSRF, allowing an attacker to execute arbitrary SQL statements, related to js/db_operations.js,… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-10188 advisory
- https://github.com/phpmyadmin/phpmyadmin/commit/c6dd6b56e236a3aff953cee4135ecaa67130e641 web
- https://github.com/phpmyadmin/composer package
- https://www.exploit-db.com/exploits/44496 web
- https://www.phpmyadmin.net/security/PMASA-2018-2 web
- http://www.securityfocus.com/bid/103936 web
- http://www.securitytracker.com/id/1040752 web