GitHub Advisoryadvisory · PyPI
GHSA-vf7j-cmrj-pmmm ZenML Server Remote Privilege Escalation Vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2024-25723
- Ecosystem
- PyPI
- Packages
- zenml
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-284
- Reviewed
- 2024-02-27
Affected packages
• PyPI zenml: < 0.42.2 → fixed in 0.42.2
• PyPI zenml: >= 0.43.0, < 0.43.1 → fixed in 0.43.1
• PyPI zenml: >= 0.45.0, < 0.46.7 → fixed in 0.46.7
• PyPI zenml: >= 0.44.0, < 0.44.4 → fixed in 0.44.4
Description
ZenML Server in the ZenML package before 0.46.7 for Python allows remote privilege escalation because the `/api/v1/users/{user_name_or_id}/activate` REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.
Related
Alias · CVE (1)
- CVE-2024-25723 ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote privilege escalation because the… vulnerability
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-25723 advisory
- https://github.com/zenml-io/zenml package
- https://github.com/zenml-io/zenml/compare/0.42.1...0.42.2 web
- https://github.com/zenml-io/zenml/compare/0.43.0...0.43.1 web
- https://github.com/zenml-io/zenml/compare/0.44.3...0.44.4 web
- https://www.zenml.io/blog/critical-security-update-for-zenml-users web