GitHub Advisoryadvisory · Maven
GHSA-vjf8-xw6c-wjhq CSRF vulnerability in Jenkins Flaky Test Handler Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2020-2237
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:flaky-test-handler
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2022-12-20
Affected packages
• Maven org.jenkins-ci.plugins:flaky-test-handler: < 1.1.0 → fixed in 1.1.0
Description
Flaky Test Handler Plugin 1.0.4 and earlier does not require POST requests for the "Deflake this build" feature, resulting in a cross-site request forgery (CSRF) vulnerability.
This vulnerability allows attackers to rebuild a project at a previous git revision where the tests were failing.
Related
Alias · CVE (1)
- CVE-2020-2237 A cross-site request forgery (CSRF) vulnerability in Jenkins Flaky Test Handler Plugin 1.0.4 and earlier allows attackers to rebuild a… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness