GitHub Advisoryadvisory · Maven
GHSA-vr35-jm2f-8wg2 Apache Syncope Vulnerable to Exposure of Sensitive Information Through Data Queries
MEDIUM
Official page ↗
- Aliases
- CVE-2026-42797
- Ecosystem
- Maven
- Packages
- org.apache.syncope.core:syncope-core-provisioning-api
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-202
- Reviewed
- 2026-06-30
Affected packages
• Maven org.apache.syncope.core:syncope-core-provisioning-api: >= 3.0.0-M0, <= 3.0.16 (no fix yet)
• Maven org.apache.syncope.core:syncope-core-provisioning-api: >= 4.0.0-M0, < 4.0.6 → fixed in 4.0.6
• Maven org.apache.syncope.core:syncope-core-provisioning-api: >= 4.1.0-M0, < 4.1.1 → fixed in 4.1.1
Description
Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope.
An administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access User-related security-sensitive information.
This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0.
Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by further restricting the JEXL expression definition.
Related
Alias · CVE (1)
- CVE-2026-42797 Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope. vulnerability
Weakness · CWE (1)
- CWE-202 Exposure of Sensitive Information Through Data Queries weakness