GitHub Advisoryadvisory · Maven

GHSA-vrvm-459q-j824 Jenkins Ansible Tower Plugin cross-site request forgery vulnerability

MEDIUM Published 2022-05-24 Modified 2023-10-26 Official page ↗
Aliases
CVE-2019-10310
Ecosystem
Maven
Packages
org.jenkins-ci.plugins:ansible-tower
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
Weaknesses
CWE-352
Reviewed
2023-10-26

Affected packages

• Maven org.jenkins-ci.plugins:ansible-tower: < 0.9.2 → fixed in 0.9.2

Description

Jenkins Ansible Tower Plugin did not perform permission checks on a method implementing form validation. This allowed users with Overall/Read access to Jenkins to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins. Additionally, this form validation method did not require POST requests, resulting in a cross-site request forgery vulnerability. This form validation method now requires POST requests and Overall/Administer permissions.

Related

Alias · CVE (1)

  • CVE-2019-10310 A cross-site request forgery vulnerability in Jenkins Ansible Tower Plugin 0.9.1 and earlier in the… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References