GitHub Advisoryadvisory · Maven
GHSA-w24g-24qg-v4w2 CSRF vulnerability in Jenkins Build With Parameters Plugin
HIGH
Official page ↗
- Aliases
- CVE-2021-21629
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:build-with-parameters
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-352
- Reviewed
- 2022-12-15
Affected packages
• Maven org.jenkins-ci.plugins:build-with-parameters: < 1.5.1 → fixed in 1.5.1
Description
Jenkins Build With Parameters Plugin 1.5 and earlier does not require POST requests for its form submission endpoint, resulting in a cross-site request forgery (CSRF) vulnerability.
This vulnerability allows attackers to build a project with attacker-specified parameters. Build With Parameters Plugin 1.5.1 requires POST requests for the affected HTTP endpoint.
Related
Alias · CVE (1)
- CVE-2021-21629 A cross-site request forgery (CSRF) vulnerability in Jenkins Build With Parameters Plugin 1.5 and earlier allows attackers to build a… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-21629 advisory
- https://github.com/jenkinsci/build-with-parameters-plugin/commit/82711e83bf822c5688017304939d5d1c3482ec3e web
- https://github.com/jenkinsci/build-with-parameters-plugin package
- https://www.jenkins.io/security/advisory/2021-03-30/#SECURITY-2257 web
- http://www.openwall.com/lists/oss-security/2021/03/30/1 web