GitHub Advisoryadvisory · RubyGems

GHSA-w3j4-76qw-wwjm Older releases of better_errors open to Cross-Site Request Forgery attack

MEDIUM Published 2021-09-07 Modified 2021-09-08 Official page ↗
Aliases
CVE-2021-39197
Ecosystem
RubyGems
Packages
better_errors
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N
Weaknesses
CWE-352
Reviewed
2021-09-07

Affected packages

• RubyGems better_errors: < 2.8.0 → fixed in 2.8.0

Description

Impact better_errors prior to 2.8.0 did not implement CSRF protection for its internal requests. It also did not enforce the correct "Content-Type" header for these requests, which allowed a cross-origin "simple request" to be made without CORS protection. These together left an application with better_errors enabled open to cross-origin attacks. _As a developer tool, better_errors documentation strongly recommends addition only to the `development` bundle group, so this vulnerability should only affect development environments. Please ensure that your project limits better_errors to the `development` group (or the non-Rails equivalent)._ Patches Starting with release 2.8.x, CSRF protection is enforced. It is recommended that you upgrade to the latest release, or minimally to "~> 2.8.3". Workarounds There are no known workarounds to mitigate the risk of using older releases of better_errors. References • Chris Moberly provided an example attack that uses a now-patched vulnerability of webpack-dev-server in conjunction with Better Errors For more information If you have any questions or comments about this advisory, please • Add to the discussion in better_errors • Open an issue in better_errors

Related

Alias · CVE (1)

  • CVE-2021-39197 better_errors is an open source replacement for the standard Rails error page with more information rich error pages. vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References