GitHub Advisoryadvisory · Maven

GHSA-w3wr-gmwf-r333 Apache InLong has Weak Password Requirements in Apache InLong

CRITICAL Published 2023-07-06 Modified 2023-07-06 Official page ↗
Aliases
CVE-2023-31098
Ecosystem
Maven
Packages
org.apache.inlong:manager-pojo
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-521
Reviewed
2023-07-06

Affected packages

• Maven org.apache.inlong:manager-pojo: >= 1.1.0, < 1.47.0 → fixed in 1.47.0

Description

Weak Password Requirements vulnerability in Apache Software Foundation Apache InLong. This issue affects Apache InLong from 1.1.0 through 1.6.0. When users change their password to a simple password (with any character or symbol), attackers can easily guess the user's password and access the account. Users are advised to upgrade to Apache InLong 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7805 to solve it.

Related

Alias · CVE (1)

  • CVE-2023-31098 Weak Password Requirements vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.1.0 through… vulnerability

Weakness · CWE (1)

  • CWE-521 Weak Password Requirements weakness

References