GitHub Advisoryadvisory · Go
GHSA-w3x4-9854-95x8 Rancher Access Control Vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2017-7297
- Ecosystem
- Go
- Packages
- github.com/rancher/rancher
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Reviewed
- 2023-07-25
Affected packages
• Go github.com/rancher/rancher: >= 1.5.0, < 1.5.3 → fixed in 1.5.3
• Go github.com/rancher/rancher: >= 1.4.0, < 1.4.3 → fixed in 1.4.3
• Go github.com/rancher/rancher: >= 1.3.0, < 1.3.5 → fixed in 1.3.5
• Go github.com/rancher/rancher: >= 1.2.0, < 1.2.4 → fixed in 1.2.4
Description
Rancher Labs rancher server 1.2.0+ is vulnerable to authenticated users disabling access control via an API call. This is fixed in versions rancher/server:v1.2.4, rancher/server:v1.3.5, rancher/server:v1.4.3, and rancher/server:v1.5.3.
Related
Alias · CVE (1)
- CVE-2017-7297 Rancher Labs rancher server 1.2.0+ is vulnerable to authenticated users disabling access control via an API call. vulnerability