GitHub Advisoryadvisory · Maven
GHSA-w595-4975-gm3h Apache Geode web-api is vulnerable to Cross-site Scripting
MEDIUM
Official page ↗
- Aliases
- CVE-2024-44088
- Ecosystem
- Maven
- Packages
- org.apache.geode:geode-web-api
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-10-14
Affected packages
• Maven org.apache.geode:geode-web-api: >= 1.1.0, < 1.15.2 → fixed in 1.15.2
Description
Malicious script injection ('Cross-site Scripting') vulnerability in Apache Geode web-api (REST). This vulnerability allows an attacker that tricks a logged-in user into clicking a specially-crafted link to execute code on the returned page, which could lead to theft of the user's session information and even account takeover.
This issue affects Apache Geode: all versions prior to 1.15.2.
Users are recommended to upgrade to version 1.15.2, which fixes the issue.
Related
Alias · CVE (1)
- CVE-2024-44088 Malicious script injection ('Cross-site Scripting') vulnerability in Apache Geode web-api (REST). vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness