GitHub Advisoryadvisory · Maven

GHSA-w5gq-xrrp-3fxf OpenNMS privilege elevation vulnerability

HIGH Published 2023-08-14 Modified 2023-08-21 Official page ↗
Aliases
CVE-2023-0872
Ecosystem
Maven
Packages
org.opennms:opennms-webapp-rest
Severity
High
CVSS vector
CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:L
Weaknesses
CWE-269
Reviewed
2023-08-14

Affected packages

• Maven org.opennms:opennms-webapp-rest: >= 31.0.8, < 32.0.2 → fixed in 32.0.2

Description

The Horizon REST API includes a users endpoint in OpenNMS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to elevation of privilege. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Erik Wynter for reporting this issue.

Related

Alias · CVE (1)

  • CVE-2023-0872 The Horizon REST API includes a users endpoint in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is… vulnerability

Weakness · CWE (1)

  • CWE-269 Improper Privilege Management weakness

References