GitHub Advisoryadvisory · Packagist

GHSA-w8fp-3gwq-gxpw Concrete CMS vulnerable to Cross-site Request Forgery

HIGH Published 2022-11-14 Modified 2025-04-30 Official page ↗
Aliases
CVE-2022-43693
Ecosystem
Packagist
Packages
concrete5/concrete5
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-352
Reviewed
2022-11-16

Affected packages

• Packagist concrete5/concrete5: < 8.5.10 → fixed in 8.5.10 • Packagist concrete5/concrete5: >= 9.0.0RC1, < 9.1.3 → fixed in 9.1.3

Description

Concrete CMS is vulnerable to CSRF due to the lack of "State" parameter for external Concrete authentication service for users of Concrete who use the "out of the box" core OAuth.

Related

Alias · CVE (1)

  • CVE-2022-43693 Concrete CMS is vulnerable to CSRF due to the lack of "State" parameter for external Concrete authentication service for users of Concrete… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References