GitHub Advisoryadvisory · Packagist
GHSA-wjg9-v8cf-f5q2 silverstripe/graphql Cross-Site Request Forgery vulnerability
HIGH
Official page ↗
- Ecosystem
- Packagist
- Packages
- silverstripe/graphql
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:H
- Weaknesses
- CWE-352
- Reviewed
- 2024-05-28
Affected packages
• Packagist silverstripe/graphql: >= 2.0.0, < 2.0.3 → fixed in 2.0.3
Description
The GraphQL controller lacked any CSRF protection, meaning authenticated users could be forced or tricked into visiting a URL that would send a GET request to the affected web server that could mutate or destroy data without the user knowing.
Related
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://github.com/silverstripe/silverstripe-graphql/commit/b59ba397ff42d8934bd2d9c932514f898c327f64 web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/silverstripe/graphql/SS-2018-007-1.yaml web
- https://github.com/silverstripe/silverstripe-graphql package
- https://www.silverstripe.org/download/security-releases/ss-2018-007 web