GitHub Advisoryadvisory · Maven

GHSA-wmcc-9vch-jmx4 Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions

HIGH Published 2025-02-04 Modified 2025-02-18 Official page ↗
Aliases
CVE-2025-23015
Ecosystem
Maven
Packages
org.apache.cassandra:cassandra-all
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-267
Reviewed
2025-02-04

Affected packages

• Maven org.apache.cassandra:cassandra-all: >= 5.0-alpha1, < 5.0.3 → fixed in 5.0.3 • Maven org.apache.cassandra:cassandra-all: >= 4.1-alpha1, < 4.1.8 → fixed in 4.1.8 • Maven org.apache.cassandra:cassandra-all: >= 4.0-alpha1, < 4.0.16 → fixed in 4.0.16 • Maven org.apache.cassandra:cassandra-all: >= 3.1, < 3.11.18 → fixed in 3.11.18 • Maven org.apache.cassandra:cassandra-all: < 3.0.31 → fixed in 3.0.31

Description

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2. Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2025-23015 Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. vulnerability

Weakness · CWE (1)

  • CWE-267 Privilege Defined With Unsafe Actions weakness

References