GitHub Advisoryadvisory · Packagist

GHSA-wpq5-q3mj-8f3r Moodle multiple cross-site request forgery (CSRF) vulnerabilities

MEDIUM Published 2022-05-13 Modified 2024-01-24 Official page ↗
Aliases
CVE-2014-7836
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Weaknesses
CWE-352
Reviewed
2024-01-24

Affected packages

• Packagist moodle/moodle: < 2.5.9 → fixed in 2.5.9 • Packagist moodle/moodle: >= 2.6.0, < 2.6.6 → fixed in 2.6.6 • Packagist moodle/moodle: >= 2.7.0, < 2.7.3 → fixed in 2.7.3

Description

Multiple cross-site request forgery (CSRF) vulnerabilities in the LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 allow remote attackers to hijack the authentication of arbitrary users for a (1) mod/lti/request_tool.php or (2) mod/lti/instructor_edit_tool_type.php request.

Related

Alias · CVE (1)

  • CVE-2014-7836 Multiple cross-site request forgery (CSRF) vulnerabilities in the LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References