GitHub Advisoryadvisory · Maven
GHSA-wq3w-3rxh-vcxx Jenkins OctoPerf Load Testing Plugin vulnerable to Cross-site Request Forgery
MEDIUM
Official page ↗
- Aliases
- CVE-2023-28671
- Ecosystem
- Maven
- Packages
- org.jenkinsci.plugins:octoperf
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2023-04-03
Affected packages
• Maven org.jenkinsci.plugins:octoperf: < 4.5.1 → fixed in 4.5.1
Description
OctoPerf Load Testing Plugin Plugin 4.5.0 and earlier does not require POST requests for a connection test HTTP endpoint, resulting in a cross-site request forgery (CSRF) vulnerability.
This vulnerability allows attackers to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.
OctoPerf Load Testing Plugin Plugin 4.5.1 requires POST requests for the affected connection test HTTP endpoint.
Related
Alias · CVE (1)
- CVE-2023-28671 A cross-site request forgery (CSRF) vulnerability in Jenkins OctoPerf Load Testing Plugin Plugin 4.5.0 and earlier allows attackers to… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness