GitHub Advisoryadvisory · PyPI

GHSA-wr6g-9wcr-cmqj Apache Superset: Improper data authorization when creating a new dataset

MEDIUM Published 2024-02-28 Modified 2025-02-13 Official page ↗
Aliases
CVE-2024-24779
Ecosystem
PyPI
Packages
apache-superset
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N
Weaknesses
CWE-863
Reviewed
2024-02-28

Affected packages

• PyPI apache-superset: < 3.0.4 → fixed in 3.0.4 • PyPI apache-superset: >= 3.1.0, < 3.1.1 → fixed in 3.1.1

Description

Apache Superset with custom roles that include `can write on dataset` and without all data access permissions, allows for users to create virtual datasets to data they don't have access to. These users could then use those virtual datasets to get access to unauthorized data. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2024-24779 Apache Superset with custom roles that include `can write on dataset` and without all data access permissions, allows for users to create… vulnerability

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References