GitHub Advisoryadvisory · Packagist

GHSA-wv9c-pfpm-4wc5 Moodle CSRF Vulnerability

HIGH Published 2022-05-24 Modified 2023-08-25 Official page ↗
Aliases
CVE-2019-10186
Ecosystem
Packagist
Packages
moodle/moodle
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-352
Reviewed
2023-07-14

Affected packages

• Packagist moodle/moodle: >= 3.7.0, < 3.7.1 → fixed in 3.7.1 • Packagist moodle/moodle: >= 3.6.0, < 3.6.5 → fixed in 3.6.5 • Packagist moodle/moodle: >= 3.5.0, < 3.5.7 → fixed in 3.5.7

Description

A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. A sesskey (CSRF) token was not being utilised by the XML loading/unloading admin tool.

Related

Alias · CVE (1)

  • CVE-2019-10186 A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References