GitHub Advisoryadvisory · Maven
GHSA-wvgr-5wgr-c6fj Jenkins mabl Plugin vulnerable to cross-site request forgery
MEDIUM
Official page ↗
- Aliases
- CVE-2023-37952
- Ecosystem
- Maven
- Packages
- com.mabl.integration.jenkins:mabl-integration
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2023-07-12
Affected packages
• Maven com.mabl.integration.jenkins:mabl-integration: < 0.0.47 → fixed in 0.0.47
Description
Jenkins mabl Plugin 0.0.46 and earlier does not perform permission checks in several HTTP endpoints.
This allows attackers with Overall/Read permission to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.
Additionally, these HTTP endpoints do not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability.
mabl Plugin 0.0.47 requires POST requests and the appropriate permissions for the affected HTTP endpoints.
Related
Alias · CVE (1)
- CVE-2023-37952 A cross-site request forgery (CSRF) vulnerability in Jenkins mabl Plugin 0.0.46 and earlier allows attackers to connect to an… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness