GitHub Advisoryadvisory · npm
GHSA-wvhm-4hhf-97x9 Cross-Site Scripting in Prism
HIGH
Official page ↗
- Aliases
- CVE-2020-15138
- Ecosystem
- npm
- Packages
- prismjs
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:L
- Weaknesses
- CWE-79
- Reviewed
- 2020-08-07
Affected packages
• npm prismjs: >= 1.1.0, < 1.21.0 → fixed in 1.21.0
Description
Impact
The easing preview of the Previewers plugin has an XSS vulnerability that allows attackers to execute arbitrary code in Safari and Internet Explorer.
This impacts all Safari and Internet Explorer users of Prism >=v1.1.0 that use the _Previewers_ plugin (>=v1.10.0) or the _Previewer: Easing_ plugin (v1.1.0 to v1.9.0).
Patches
This problem is patched in v1.21.0.
Workarounds
To workaround the issue without upgrading, disable the easing preview on all impacted code blocks. You need Prism v1.10.0 or newer to apply this workaround.
References
The vulnerability was introduced by this commit on Sep 29, 2015 and fixed by Masato Kinugawa (#2506).
For more information
If you have any questions or comments about this advisory, please open an issue.
Related
Alias · CVE (1)
- CVE-2020-15138 Prism is vulnerable to Cross-Site Scripting. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness