GitHub Advisoryadvisory · RubyGems

GHSA-ww4x-rwq6-qpgf OmniAuth Ruby gem Cross-site Request Forgery in request phase

HIGH Published 2019-05-29 Modified 2024-02-15 Official page ↗
Aliases
CVE-2015-9284
Ecosystem
RubyGems
Packages
omniauth
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-352
Reviewed
2019-05-29

Affected packages

• RubyGems omniauth: < 2.0.0 → fixed in 2.0.0

Description

The request phase of the OmniAuth Ruby gem (1.9.2 and earlier) is vulnerable to Cross-Site Request Forgery when used as part of the Ruby on Rails framework, allowing accounts to be connected without user intent, user interaction, or feedback to the user. This permits a secondary account to be able to sign into the web application as the primary account. As of v2 OmniAuth no longer has the vulnerable configuration by default, but it is still possible to configure OmniAuth in such a way that the web application becomes vulnerable to Cross-Site Request Forgery. There is a recommended remediation described here.

Related

Alias · CVE (1)

  • CVE-2015-9284 The request phase of the OmniAuth Ruby gem (1.9.1 and earlier) is vulnerable to Cross-Site Request Forgery when used as part of the Ruby on… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References