GitHub Advisoryadvisory · Packagist
GHSA-wxmq-v9gx-75pg Moodle vulnerable to Cross-site Request Forgery
HIGH
Official page ↗
- Aliases
- CVE-2023-28335
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-352
- Reviewed
- 2023-03-23
Affected packages
• Packagist moodle/moodle: >= 4.1.0, < 4.1.2 → fixed in 4.1.2
Description
The link to reset all templates of a database activity did not include the necessary token to prevent a CSRF risk.
Related
Alias · CVE (1)
- CVE-2023-28335 The link to reset all templates of a database activity did not include the necessary token to prevent a CSRF risk. vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-28335 advisory
- https://github.com/moodle/moodle/commit/355556c05f4a6d9e223164eff820cd34eb70cc35 web
- https://bugzilla.redhat.com/show_bug.cgi?id=2179424 web
- https://git.moodle.org/gw?p=moodle.git;a=commitdiff;h=355556c05f4a6d9e223164eff820cd34eb70cc35 web
- https://github.com/moodle/moodle package
- https://moodle.org/mod/forum/discuss.php?d=445067 web