GitHub Advisoryadvisory · Maven
GHSA-x24m-wr2f-p3vc Jenkins Google Compute Engine Plugin Cross-Site Request Forgery vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2019-16548
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:google-compute-engine
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
- Weaknesses
- CWE-352
- Reviewed
- 2022-12-06
Affected packages
• Maven org.jenkins-ci.plugins:google-compute-engine: < 4.2.0 → fixed in 4.2.0
Description
A cross-site request forgery vulnerability in Jenkins Google Compute Engine Plugin 4.1.1 and earlier in ComputeEngineCloud#doProvision could be used to provision new agents. Google Compute Engine Plugin 4.2.0 requires POST requests for this API endpoint.
Related
Alias · CVE (1)
- CVE-2019-16548 A cross-site request forgery vulnerability in Jenkins Google Compute Engine Plugin 4.1.1 and earlier in ComputeEngineCloud#doProvision… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness