GitHub Advisoryadvisory · Maven
GHSA-x25h-f84x-wh4m CSRF vulnerability in Jenkins RocketChat Notifier Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2022-28138
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:rocketchatnotifier
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2022-11-29
Affected packages
• Maven org.jenkins-ci.plugins:rocketchatnotifier: < 1.5.0 → fixed in 1.5.0
Description
Jenkins RocketChat Notifier Plugin 1.4.10 and earlier does not perform a permission check in a method implementing form validation.
This allows attackers with Overall/Read permission to connect to an attacker-specified URL using attacker-specified credential.
Additionally, this form validation method does not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability.
RocketChat Notifier Plugin 1.5.0 requires POST requests and Overall/Administer permission for the affected form validation method.
Related
Alias · CVE (1)
- CVE-2022-28138 A cross-site request forgery (CSRF) vulnerability in Jenkins RocketChat Notifier Plugin 1.4.10 and earlier allows attackers to connect to… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness