GitHub Advisoryadvisory · Maven
GHSA-x263-hp5c-p2rj Jenkins OctoPerf Load Testing Plugin vulnerable to Cross-site Request Forgery
MEDIUM
Official page ↗
- Aliases
- CVE-2023-28674
- Ecosystem
- Maven
- Packages
- org.jenkinsci.plugins:octoperf
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2023-04-03
Affected packages
• Maven org.jenkinsci.plugins:octoperf: < 4.5.3 → fixed in 4.5.3
Description
OctoPerf Load Testing Plugin Plugin 4.5.2 and earlier does not perform permission checks in several HTTP endpoints.
This allows attackers with Overall/Read permission to connect to a previously configured Octoperf server using attacker-specified credentials.
Additionally, these endpoints do not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability.
OctoPerf Load Testing Plugin Plugin 4.5.3 requires POST requests and the appropriate permissions for the affected HTTP endpoints.
Related
Alias · CVE (1)
- CVE-2023-28674 A cross-site request forgery (CSRF) vulnerability in Jenkins OctoPerf Load Testing Plugin Plugin 4.5.2 and earlier allows attackers to… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness