GitHub Advisoryadvisory · Maven
GHSA-x546-xrx3-hjx4 Jenkins Dynatrace Plugin vulnerable to Cross-Site Request Forgery
HIGH
Official page ↗
- Aliases
- CVE-2019-10462
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:dynatrace-dashboard
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2022-12-06
Affected packages
• Maven org.jenkins-ci.plugins:dynatrace-dashboard: < 2.1.4 → fixed in 2.1.4
Description
A cross-site request forgery vulnerability in Jenkins Dynatrace Application Monitoring Plugin prior to 2.1.4 allows attackers to connect to an attacker-specified URL using attacker-specified credentials.
NOTE: This plugin is marked as DEPRECATED
Related
Alias · CVE (1)
- CVE-2019-10462 A cross-site request forgery vulnerability in Jenkins Dynatrace Application Monitoring Plugin 2.1.3 and earlier allowed attackers to… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-10462 advisory
- https://github.com/jenkinsci/dynatrace-plugin/commit/373adaa1161d59ccd4e5e3469a9b6aeec17968ae web
- https://github.com/jenkinsci/dynatrace-plugin package
- https://jenkins.io/security/advisory/2019-10-23/#SECURITY-1483%20(1) web
- http://www.openwall.com/lists/oss-security/2019/10/23/2 web