GitHub Advisoryadvisory · npm
GHSA-xhcr-j4j9-3gh7 Language Servers for AWS Vulnerable to Arbitrary Code Execution
HIGH
Official page ↗
- Aliases
- CVE-2026-12957
- Ecosystem
- npm
- Packages
- @aws/lsp-codewhisperer
- Severity
- High
- CVSS vector
- CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Weaknesses
- CWE-732
- Reviewed
- 2026-09-24
Affected packages
• npm @aws/lsp-codewhisperer: < 0.0.113 → fixed in 0.0.113
Description
Summary
Language Servers for AWS (the aws/language-servers project) provide the underlying language-server runtime that powers Amazon Q Developer's AI coding assistance across its IDE plugins (Visual Studio Code, JetBrains, Eclipse, and
Visual Studio).
Improper trust boundary enforcement in Language Servers for AWS may allow for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically
executed.
Impact
When a local user opens a maliciously crafted workspace and trusts it when prompted, commands defined in the workspace's project-level configuration files may be executed automatically, resulting in arbitrary code execution on the
user's host.
This issue is triggered when a user opens a workspace, trusts it, and the agent subsequently executes commands defined in the project-level configuration files.
Impacted versions: Language Servers for AWS version <1.65.0.
Patches
This issue has been addressed in Language Servers for AWS version 1.65.0. We recommend upgrading to the latest version and ensuring any forked or derivative code is patched to incorporate the new fixes.
Workarounds
No workarounds are available.
References
If you have any questions or comments about this advisory, AWS Security asks that you contact them via their vulnerability reporting page or directly via email to [email protected]. Please do not create a public GitHub issue.
Acknowledgement
AWS Security would like to thank Wiz and Maor Dokhanian for collaborating on this issue through the coordinated vulnerability disclosure process.
Related
Alias · CVE (1)
- CVE-2026-12957 Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary… vulnerability
Weakness · CWE (1)
- CWE-732 Incorrect Permission Assignment for Critical Resource weakness
References
- https://github.com/aws/language-servers/security/advisories/GHSA-xhcr-j4j9-3gh7 web
- https://nvd.nist.gov/vuln/detail/CVE-2026-12957 advisory
- https://github.com/Amazon-Q-Developer/language-servers/pull/2708 web
- https://github.com/Amazon-Q-Developer/language-servers/pull/2711 web
- https://github.com/Amazon-Q-Developer/language-servers/commit/7b8595a4e638562f79d5f71dcf22b0c700490458 web
- https://github.com/Amazon-Q-Developer/language-servers/commit/f5aa1a3b25aa38bfe8dd0e830b5839e1cea1d410 web
- https://aws.amazon.com/security/security-bulletins/2026-047-aws web
- https://github.com/Amazon-Q-Developer/language-servers/releases/tag/agentic-rc-1.65.0 web
- https://github.com/aws/language-servers package