GitHub Advisoryadvisory · Packagist
GHSA-xjg6-5v39-v7fc Concrete CMS is vulnerable to CSRF via Backend\File::approveVersion
LOW
Official page ↗
- Aliases
- CVE-2026-8340
- Ecosystem
- Packagist
- Packages
- concrete5/concrete5
- Severity
- Low
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
- Weaknesses
- CWE-352
- Reviewed
- 2026-06-29
Affected packages
• Packagist concrete5/concrete5: < 9.5.1 → fixed in 9.5.1
Description
Concrete CMS 9.5.0 and below is vulnerable to CSRF via Backend\File::approveVersion. Victim with edit_file_contents permission is CSRF'd into publishing an attacker-chosen previously-uploaded version (downgrade to an older version of a file, or activation of a co-editor's unpublished version). Thanks Winston Crooker for reporting.
Related
Alias · CVE (1)
- CVE-2026-8340 Concrete CMS 9.5.0 and below is vulnerable to CSRF via Backend\File::approveVersion. vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness