GitHub Advisoryadvisory · Packagist
GHSA-xjr3-fwp9-9g96 Moodle Cross-Site Request Forgery (CSRF)
HIGH
Official page ↗
- Aliases
- CVE-2022-2986
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-352
- Reviewed
- 2024-04-23
Affected packages
• Packagist moodle/moodle: >= 3.11, < 3.11.9 → fixed in 3.11.9
• Packagist moodle/moodle: >= 4.0, < 4.0.3 → fixed in 4.0.3
Description
Enabling and disabling installed H5P libraries did not include the necessary token to prevent a CSRF risk.
Related
Alias · CVE (1)
- CVE-2022-2986 Enabling and disabling installed H5P libraries did not include the necessary token to prevent a CSRF risk. vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness