GitHub Advisoryadvisory · RubyGems
GHSA-xq52-rv6w-397c Directive injection when using dynamic overrides with user input
MEDIUM
Official page ↗
- Aliases
- CVE-2020-5217
- Ecosystem
- RubyGems
- Packages
- secure_headers
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-95
- Reviewed
- 2020-01-23
Affected packages
• RubyGems secure_headers: >= 6.0.0, < 6.2.0 → fixed in 6.2.0
• RubyGems secure_headers: >= 5.0.0, < 5.1.0 → fixed in 5.1.0
• RubyGems secure_headers: < 3.8.0 → fixed in 3.8.0
Description
Impact
If user-supplied input was passed into `append/override_content_security_policy_directives`, a semicolon could be injected leading to directive injection.
This could be used to e.g. override a `script-src` directive. Duplicate directives are ignored and the first one wins. The directives in `secure_headers` are sorted alphabetically so they pretty much all come before `script-src`. A previously undefined directive would receive a value even if `SecureHeaders::OPT_OUT` was supplied.
The fixed versions will silently convert the semicolons to spaces and emit a deprecation warning when this happens. This will result in innocuous browser console messages if being exploited/accidentally used. In future releases, we will raise application errors resulting in 500s.
> Duplicate script-src directives detected. All but the first instance will be ignored.
See https://www.w3.org/TR/CSP3/#parse-serialized-policy
> Note: In this case, the user agent SHOULD notify developers that a duplicate directive was ignored. A console warning might be appropriate, for example.
Patches
Depending on what major version you are using, the fixed versions are 6.2.0, 5.1.0, 3.8.0.
Workarounds
If you are passing user input into the above methods, you could filter out the input:
```ruby
override_content_security_policy_directives(:frame_src, [user_input.gsub(";", " ")])
```
References
Reported in https://github.com/twitter/secure_headers/issues/418
https://www.w3.org/TR/CSP3/#parse-serialized-policy
For more information
If you have any questions or comments about this advisory:
• Open an issue in this repo
• DM @ndm on twitter
Related
Alias · CVE (1)
- CVE-2020-5217 In Secure Headers (RubyGem secure_headers), a directive injection vulnerability is present in versions before 3.8.0, 5.1.0, and 6.2.0. vulnerability
Weakness · CWE (1)
- CWE-95 Improper Neutralization of Directives in Dynamically Evaluated Code weakness
References
- https://github.com/twitter/secure_headers/security/advisories/GHSA-xq52-rv6w-397c web
- https://nvd.nist.gov/vuln/detail/CVE-2020-5217 advisory
- https://github.com/twitter/secure_headers/issues/418 web
- https://github.com/twitter/secure_headers/pull/421 web
- https://github.com/twitter/secure_headers/commit/936a160e3e9659737a9f9eafce13eea36b5c9fa3 web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/secure_headers/CVE-2020-5217.yml web
- https://github.com/twitter/secure_headers package